Requirements For Database Backup Using SSH

In this guide, you’ll learn about few command-line tools required before you can configure database backup using SSH

PostgreSQL - psql, pg_dump and server version

When setting up PostgreSQL backups using an SSH server, please ensure that you have the following CLI tools installed and their version number is equal to or higher than the database version you are trying to backup.

psql

pg_dump

Both psql and pg_dump are equal to or higher than the database version


MySQL - mysql, mysqldump and server version

When setting up MySQL backups using an SSH server, please ensure that you have the following CLI tools installed and their version number is equal to or higher than the database version you are trying to backup.

mysql

mysqldump

Both mysql and mysqldump are equal to or higher than the database version